Monday 15th July 2019

Broadcaster Live365 Partial network Interruption

Update - 7:27 PM ET The Live365 platform has been stable since 5:05 PM ET. The network service which caused this issue has been patched and we do not expect it to cause any further issues. We appreciate everyone's patience and understanding during this event! Thank you for being a part of the Live365 community!

Update - 4:58 PM ET Our Engineering team is monitoring the situation. All stations which were impacted by the brief network outage are back up and streaming just fine. It appears the majority of listeners were not affected, but perhaps heard a "blip" here and there. We will update as we learn more about the situation or resolve it fully. Thanks

At 4:42 PM ET, we started to receive reports from our monitoring services that the Live365 servers were having issues connecting to the general Internet. We are actively investigating if this issue is isolated to one of our datacenters, or more widespread across the U.S. We are actively investigating and will keep everyone updated here. Thank you for your patience.