Tuesday 2nd April 2019

Missing song art work and station logos on Live365

Update 3:15 PM ET, 04/04 Live365 accounts who were affected by missing art work or logos were contacted 2 days ago by our Corporate team, and our Solutions team has been working with those customers through the help desk. Many stations which were missing graphic assets are now seeing them displayed. However, there are still data recovery efforts under way. These digital forensics tasks are resource intensive, and we anticipate having a definitive update on this within the next 7 days. Please do reach out to us through the help desk with any questions or concerns you may have. All teams are continuing to monitor our server infrastructure, and we appreciate all of the support and feedback our community has passed our way. Thank you !

Update 9:55 AM ET, 04/03 We are continuing to see great improvements across our stations with album art work being displayed within station libraries. Our Engineering team is continuing to conduct data recovery efforts, and we are updating our broadcasters through ticketing communications. Please do reach out to us at support@live365.com if you'd like our assistance or for more info. Thanks

Update 11:26 AM ET Missing song art work and station logos - Our Engineering team has been hard at work since Sunday conducting data recovery and file re-importing processes in order to attempt to restore as many images as possible to the stations experiencing this issue. If you have not done so already, please open a ticket with us if your station is affected by this. We’ll continue to keep up you updated here. Thanks for your continued patience!