Saturday 7th May 2022

Broadcaster Partial Interruption

Update 03:00 PM ET: This incident has been resolved.


Update 02:00 PM ET: A fix has been implemented and we are monitoring the results.


Our monitoring systems alerted us about a potential incident with file uploads and album artwork for some Live365 stations. We've isolated this to an issue with a data center partner, and the engineering team is investigating currently. It does not appear that any streaming mode or listener traffic has been affected.

Thank you for your patience!