Wednesday 1st December 2021

Live365 - Degraded Dashboard & Directory Functionality

We have identified an incident with the Live365 Dashboard & station Directory functionality, which is causing some users to experience issues navigating their account and station directory. Our engineering team is investigating and should come to a resolution shortly.


Update, 5:39 PM ET A fix was put in place by our engineers to restore normal Dashboard functionality. We are still investigating issues with the station directory (particularly with last played information).



Update, 6:49 PM ET An additional fix has been implemented and last played information is now displaying properly. It may take some time for the last played list to fully populate.


Thank you for your patience!