Friday 12th February 2021

Broadcaster Live365 Dashboard - Lock up state for some stations

Update 07:22 PM ET All systems appear to be returning to normal at this time, and we'll continue monitoring the situation for the next few hours but we consider it fixed now.

Update 6:22 PM ET This issue affects some stations which are running in scheduled or auto DJ mode, Our Engineers have identified the problem and they are working to resolve it.

At 05:22 PM ET, some stations on the Live365 Dashboard system reported being in a locked up state. Our engineers were alerted immediately and are investigating in order to reach a prompt resolution. Thank you for your patience!