Tuesday 27th October 2020

Live365 - Broadcaster and Streaming Network

Update - 15:17 PM ET Our engineers have confirmed the issue has been fixed and Autodj for these affected stations it is functional again.

Update - 15:00 PM ET Our engineers were able to identify the issue and they are working for a fix currently. Thank you for your understanding!

** At 14:15 AM ET** Some stations on the Live365 system reported problems on schedule and Autodj mode. Our engineers were alerted immediately and are investigating in order to reach a prompt resolution. Thank you for your patience!